All systems operational

An Issue has been identified and the version is currently being rolled back.

Resolved
Operational
Started about 2 months ago Lasted 21 minutes

Affected

Australasia
Phocas Analytics - AU
Phocas Budget and Forecasting - AU
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.