All systems operational

We are investigating reports of degraded availability for B&F

Resolved
Degraded performance
Started over 1 year ago Lasted about 2 hours

Affected

North America
Phocas Budget and Forecasting - US
Updates
  • Resolved
    Resolved

    B&F is now fully operational.

  • Monitoring
    Monitoring

    We continue to work on the issue and expect B&F to be fully operational in 30 minutes.

  • Identified
    Update

    We are still working to resolve issues with B&F.

    The root cause has been identified however customers may still experience issues.

  • Identified
    Identified

    B&F is experiencing degraded performance. We are still investigating and will provide an update when we have one.

  • Investigating
    Investigating

    We are currently investigating this incident.