All systems operational

Upgrade Phocas to version 8.1.31 - USA

Completed
Scheduled for August 20, 2023 at 11:00 PM – 11:19 PM

Affects

North America
Phocas Analytics - US
Phocas Budget and Forecasting - US
Phocas Analytics - Canada
Phocas Budget and Forecasting - Canada
Updates
  • Completed
    August 20, 2023 at 11:19 PM
    Completed
    August 20, 2023 at 11:19 PM

    Maintenance has completed successfully.

  • In progress
    August 20, 2023 at 11:00 PM
    In progress
    August 20, 2023 at 11:00 PM

    Maintenance is now in progress

  • Planned
    August 20, 2023 at 11:00 PM
    Planned
    August 20, 2023 at 11:00 PM

    Releasing the latest version of Phocas to customers, to provide new or enhanced features and functionality and bug fixes.