All systems operational

Upgrade Phocas to hotfix version 8.1.27.7 - USA & Canada

Completed
Scheduled for May 25, 2023 at 3:00 AM – 4:00 AM

Affects

North America
Phocas Analytics - US
Phocas Budget and Forecasting - US
Phocas Analytics - Canada
Phocas Budget and Forecasting - Canada
Updates
  • Completed
    May 25, 2023 at 4:00 AM
    Completed
    May 25, 2023 at 4:00 AM

    Maintenance has completed successfully

  • In progress
    May 25, 2023 at 3:00 AM
    In progress
    May 25, 2023 at 3:00 AM

    Maintenance is now in progress

  • Planned
    May 25, 2023 at 3:00 AM
    Planned
    May 25, 2023 at 3:00 AM

    Releasing the latest version of Phocas to customers, to provide new or enhanced features and functionality and bug fixes.