All systems operational

Upgrade Phocas to version 8.1.25 - UKS

Completed
Scheduled for March 20, 2023 at 6:00 PM – 7:00 PM

Affects

Europe
Phocas Analytics - UK
Updates
  • Completed
    March 20, 2023 at 7:00 PM
    Completed
    March 20, 2023 at 7:00 PM

    Maintenance has completed successfully

  • In progress
    March 20, 2023 at 6:00 PM
    In progress
    March 20, 2023 at 6:00 PM

    Maintenance is now in progress

  • Planned
    March 20, 2023 at 6:00 PM
    Planned
    March 20, 2023 at 6:00 PM

    Releasing the latest version of Phocas to customers, to provide new or enhanced features and functionality and bug fixes.