All systems operational

Unplanned service outage

Resolved
Partial outage
Started over 1 year ago Lasted 39 minutes

Affected

North America
Phocas Analytics - US
Phocas Budget and Forecasting - US
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    The organizations on the USA Phocas Cloud are accessible. We will continue to investigate the issue.

  • Investigating
    Investigating

    We are currently experiencing an issue that is impacting some customers.

    Phocas may not be accessible and customers may be experiencing errors.

    Data may not able to be loaded at this time.

    We are currently investigating the cause and will provide an update as soon as possible